分類
WordPress

升級 WordPress 2.2 失敗

目前只有後台進的去,前台頁面統統看不到 Q_Q

正在想辦法解決中,請耐心等待……..(我自己快沒耐心了) 此時為上午十點多 Q_Q

update: 2007/05/16 12:06
經過一個多小時的 CPR 搶救之後,恢復正常了。

老實說我是暴力升級法,通通覆蓋過去,雖然在 local 端測試沒問題,但是上傳之後問題一堆,老樣子,建議先備份資料庫,然後再關閉 plugins ,最後再升級。

不要學我用暴力方法升級,結果惹來一堆麻煩。

作者: Eduardo

在大台北地區出沒,網路愛好者,平時喜歡逛網站接收最新資訊,WordPress 13年經驗,提供WordPress客製化服務。

在〈升級 WordPress 2.2 失敗〉中有 20 則留言

Hi 艾德 兄:

還記得我之前跟你說2.13-2.2升級有問題嗎

剛好我之前用的主機商Acsite,她們目前營運似乎出現了問題
客服從今年開始就已經若有似無,到4月更是整個消失不見
雖然我到11月才到期Orz
不過我還是趕緊搬離到Q168.net

後來發現該公司的主機有提供2.2版的wordpress安裝
我就想說我的2.1.3是否可以順利升級
今天早上(昨天才搬家完成)就馬上升級到最新的2.2.1
結果完全沒問題

後來我去比較一下兩者之間的PHP版本

Acsite:
MySQL 版本 4.0.27-standard
PHP 版本 4.3.11
PERL 版本 5.8.6

Q168:
MySQL 版本 4.0.27-standard-log
PHP 版本 4.4.7
PERL 版本 5.8.7

發現Q168的PHP版本比較新
可能是因為這樣才能夠更新到2.2
提供給您做個參考!!
以後有任何問題還希望您能不吝指教!!
謝謝

[…] 剛剛在610學長那邊看到更新訊息,這次是安全更新,為了避免站台被打爆,還是趕快更新才好,這次好像也修正了IE7的Widgets顯示問題。說起來這是我第一次更新呀,想到手就會抖,之前網路上有太多放槍的慘劇了。這次參考了Taiwan2.0上面的指導才搞定。大概說一下我的流程好了,以下全都是SSH在Shell下搞定。 […]

這部份應該是版本問題,也不排除是 Kirin 說的,還是你後台有開啟gzip 文章壓縮
若瀏覽器支援,WordPress 應使用壓縮格式(gzip)傳送文章
這個通常關掉比較好

艾德兄~我的版本

MySQL 版本 4.0.27-standard
PHP 版本 4.3.11
PERL 版本 5.8.6

那請問這是什麼原因導致呢??
因為我也有去問Kirin兄
———————————————————
Kirin Lin
2007 年 06 月 16 日 9:11 下午
To Jie,
那是快取有問題。升級時請把 define(’ENABLE_CACHE’, true); 這行註解掉,並將 /wp-content/cache/ 這個資料夾內容清空。升級完畢後再將該設定設好。
———————————————————-
但是我登入主機之後
發現裡面沒有cache資料夾
所以也不知道問題到底出在哪Orz

有可能是 php & MySql & Zend 的版本問題
能公佈一下版本嗎? 或者嘗試升級這些程式到最新版

國外好像有人把版本升級就解決的樣子

請問艾德兄

小弟從2.13升級成2.2
但是卻出現了以下錯誤
Warning: Illegal offset type in /home/hux82889/public_html/wp-includes/cache.php on line 125
[delete]
Warning: Illegal offset type in unset in /home/hux82889/public_html/wp-includes/cache.php on line 282

請問這是什麼原因呢???

昨晚付了 BlueHost 錢, 當下主機立即開通, 我將 WP2.2 丟上去, 修改一下 wp-config.php 再丟上去, 然後把資料庫弄上去, 最後去設定 DNS, 結果就弄好了…
真是出乎我的意料。

另外, 請問艾德兄, wordpress 發信亂碼是修改哪一個檔案呢?

官網有提到,內建的 plugin 有優化,也就是提昇整體的執行速度,不過感覺起來是有那麼快一點點,應該有更多的地方等著挖掘。

我在升級的時候也折騰了半天,主要是裝上去全變亂碼了,弄了半天還是全部重裝再重導數據才弄好
不過感覺2.2的速度快了不少
難道是我錯覺???

大家看看會不會是php版本的問題~
我將php更新成4.4.7就沒問題了~我也不知道為什麼!
可以更新php版本的人不妨試試看!!

我之前所有升級的經驗都很不愉快,所以還是不急著做升級動作了,目前我的WP還是停留在2.0.9的舊版本:P

做人,還是保守一點的好XD

發佈留言

發佈留言必須填寫的電子郵件地址不會公開。 必填欄位標示為 *